
 
 
 

The mission of the United Nations Office for the Coordination of Humanitarian Affairs (OCHA) is to 
Coordinate the global emergency response to save lives and protect people in humanitarian crises. 

We advocate for effective and principled humanitarian action by all, for all. 
www.unocha.org 

 

 

Introduction 

Power Query is an excel build in function that can be used in different stages of the Information Management cycle. It 
allows you to: 

1- Data collection: connect to data collected from different sources from different locations i.e. excel sheets, text 
files, sharepoint, kobo, google sheets and other online sources. 

2- Data cleaning: collected data can be verified and corrected, categorized, merged and combined. 

Steps of data operations are saved as “Applied Steps” that can be reviewed, amended, shared and automate future 
processes. 

Output dataset: Power query output is processed and consolidated data to be used in later phases i.e. analysis and 
visualizations. 

 

A key success of using power query is to develop the script in a way that allows it to be shared 
and minimal updates are needed to be done by the people intending to use it. 

  

Using Power Query for Excel  
 

In Humanitarian Context 
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Data Preparation 

1.  It’s a good practice to standardize column names of the different datasets. This step helps in matching fields from 
different datasets so they can be “combined” regardless whether they were in same order or not. HXL allows you to do 
so. Add new row under the main header (in grey) and add the HXL tags (shown in yellow). 

 

2.  It’s highly recommended to have your dataset defined in tables in excel so you can only import only needed dataset. 
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Connection to data source and consolidating in master table 

1. Create connection to your tables i.e. one connection per cluster, without importing the full table unless needed: 

 

Do this step for every dataset you want to use i.e. all clusters data 

2. Combine datasets together i.e. clusters data consolidated all in master connection/sheet as explained below: 
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For successful application of the Combine function, it is important to have all columns of all tables has standard 
similar names i.e. HXL as explained in the first step page so that values of same columns go correctly under each 
other. 

 

Applying data processing functions 

1. Correct data Types of all columns: 
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2. Make necessary basic data manipulation, cleaning and processing needed for each data source, steps can be done 
differently than explained below: 

 

Note: The most important feature of Power Query is that it saves your work in steps so you can track, undo or customize 
steps (what has been done) without having to delete the steps. Below is a summary steps of what has been done in the 
above illustration: 
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3. Make Advanced data processing operations: 

Split and merge columns 
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Add Conditional Columns 
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Add Custom Columns 
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Standardizing/categorizing values 

This step is critical in case you want to create standard names or categorize values i.e. cluster names, type of 
organizations…etc. The steps are explained below:  

1. Create lists of values; These should contain original names that should be replaced together with the standard name 
format that will be replaced with. We will call these lists as vocabularies, sometimes they are called data dictionary. 
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2. Now create connection to this table (vocabulary): 
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3. Now you can add this table to the master connection/table that has consolidated cluster data. The reason for that is 
to add the standard column(s)/categories to the master sheet. 
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4. Unpivot data i.e. summaries multiple columns values into rows 
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Connecting to different data sources 

Connect to Sharepoint: 

 
 

  



 
OCHA | 15 of 28 

 

United Nations Office for the Coordination of Humanitarian Affairs 
www.unocha.org 

Connect to KOBO: 

1. Create connection to Kobo API and import collected data. A step by step guide can be found here: 
(http://support.kobotoolbox.org/en/articles/1559346-pulling-your-data-into-excel-power-query) 

2. The importance of importing the data collected in kobo is that excel data will be updated with new collected data every 
time you refresh the connection in Power Query. 

 

Connect to Google sheet: 

1. Open the google sheet (with sharing settings set to Edit – anyone with the link)/ 

2. Get the web link of your sheet to be used in Power Query: 

o Go to File>Download as>Microsoft Excel OR Comma-separated values OR Tab-Separated values 

o CTRL+J and you will see the history of downloaded files, right click the sheet and copy link address 

. 

o Paste the link as URL for data source from Data-> “From Web” in Power Query.  
 

  

http://support.kobotoolbox.org/en/articles/1559346-pulling-your-data-into-excel-power-query
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Connect to FINANCIAL TRACKING SERVICE (FTS) 

Create a function that collect the data for X country(s) using the API. The exercise can be generalized to be used for 
funding received within the Plan, requirements and total funding. 

To connect and get updated to recent dataset do the following: 

1. Connect to APIs (for more information about the HPC APIs please check here: https://api.hpc.tools/docs/v1/)  

Plan Funding: https://api.hpc.tools/v1/public/fts/flow?planid="&Number.ToText(appealID)&"&limit=100000&format=json 

Plan Requirement: https://api.hpc.tools/v1/public/fts/flow?planid="&Number.ToText(appealID)&"&groupBy=cluster&format=json 

Total Funding: https://api.hpc.tools/v1/public/fts/flow?locationid="&Number.ToText(ctryID)&"&year=2019&limit=100000&format=json 

Notes:  

- Replace “planid=&Number.ToText(appealID)” with the country PlanID. 

- APIs are better to be called from within functions. 

2. Create Vocabularies Tables 

o Create a table listing previous year’s donors (exact names as per FTS) in one column and their acronym in the 
other. 

o Create a table listing clusters names in one column  (exact names as per FTS) within the country Plan and 
“correct version” (how you would like the clusters names to appear on your visual) in the other column. 

o Create a table listing in the first column the appealing organizations (exact names as per FTS) and the second 
column their acronyms 

o Create a table listing in the first column the country name (exact name as per FTS), in the second column the ISO 
code and in the third column the country’s PlanID 

3. Link Table to Functions 

Call each Function by following the below steps:  

o On Data (in the Menu), click on Get Data –> From Other Sources -> Blank Query 

o Create a list of ISO3 with the above-mentioned columns 

o Convert it to table and give It a title 

4. STEP3: MERGING THE TABLES 

o Merge the Appealing organizations, Donors and Clusters tables with the Plan Funding Table 

o Merge the Clusters tables with the Requirement Table then Expand 

o The Plan funding table will show the list of organizations that have requested funds within the Plan and have 
received the funds within it, as well as the donor per project and the corresponding fund 

o The Requirement table will show the funding per cluster 

The Total Funding will show the amount that was funded inside and outside the Plan. In order to extract the total amount 
received outside the Plan, subtract the sum of the Total Funding with the sum of the sum of the Plan Funding. It is 
important to note that it cannot be disaggregated by cluster/sector.  

https://api.hpc.tools/docs/v1/
https://api.hpc.tools/v1/public/fts/flow?planid=%22&Number.ToText(appealID)&%22&limit=100000&format=json
https://api.hpc.tools/v1/public/fts/flow?planid=%22&Number.ToText(appealID)&%22&groupBy=cluster&format=json
https://api.hpc.tools/v1/public/fts/flow?locationid=%22&Number.ToText(ctryID)&%22&year=2019&limit=100000&format=json
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Connect to DEEP: 

Create connection to DEEP and import collected data. A step by step guide can be found here: 
(https://docs.google.com/document/d/1TBeRRi5UgZX0APzAua1HX12V57RPAzEjaqhXZjCAOhg/edit) 

And also Illustrative video (https://drive.google.com/file/d/18W0r9fkwKe_DoiH-9IZ0sD-E3yw7cKPR/view)  

Note:  

To successfully establish connection to kobo, make sure to append the string '?limit=25&format=json' at the end of 
the link to load limited data while using browser. i.e. if you are planning to get the list of projects I.e the api link to the 
projects would be something like this ('https://api.thedeep.io/api/v1/projects/’) then you need to add use 
('https://api.thedeep.io/api/v1/projects/?limit=25&format=json') for Power Query to work which limits the number of rows 
to 25. However Pwer BI can import unlimited number of rows. 

Due to large number of data set, trying to pull all at once will give timeout error so it's best to use pagination to load 
large data using limit. You can use the limit parameter to provide how much entity you want per requests as explained 
earlier so appending ?limit=10 will provide 10 entity per request for the used API. 

 

Power query/PBI doesn't provide pagination right out of box, but you can construct query to load all the required data. 

https://stackoverflow.com/questions/46904641/how-to-get-paginated-data-from-api-in-power-bi 

so that you would use https://api.thedeep.io/api/v1/projects/?limit=10 for the url and use offset instead of page 
similar to this https://api.thedeep.io/api/v1/projects/?limit=10&offset=10. 

 

 

  

https://docs.google.com/document/d/1TBeRRi5UgZX0APzAua1HX12V57RPAzEjaqhXZjCAOhg/edit
https://drive.google.com/file/d/18W0r9fkwKe_DoiH-9IZ0sD-E3yw7cKPR/view
https://stackoverflow.com/questions/46904641/how-to-get-paginated-data-from-api-in-power-bi
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Connect to ACLED 

Note: The Armed Conflict Location & Event Data Project (ACLED) is a disaggregated conflict analysis and crisis mapping 
project. ACLED is the highest quality, most widely used, realtime data and analysis source on political violence and 
protest in the developing world. Practitioners, researchers and governments depend on ACLED for the latest reliable 
information on current conflict and disorder patterns. Visit it here https://www.acleddata.com.  

To connect and get updated to recent dataset do the following: 

1. Create a function in Power Query that’s main functionality is to connect to specific country(s) data using the API as 
follow: 

o Data on the menu -> Get Data -> From Web 

o The API to connect is: Web.Contents ("https://api.acleddata.com/acled/read?terms=accept"). A full guide for 
using ACLED API can be found here (https://www.acleddata.com/wp-content/uploads/2013/12/API-User-

Guide-August-2017.pdf)   

Name the Function (in the example: fnGet_Ctry). Below is an example for such function:  

(= (iso3_id)=> 

let 

    Source 
=Json.Document(Web.Contents("https://api.acleddata.com/acled/read?terms=accept&limit=1000000&iso3="&iso3_id&"&year=2012|2019&year_where=BETWEE
N")), 

    //Source 
=Json.Document(Web.Contents("https://api.acleddata.com/acled/read?terms=accept&limit=1000000&iso3=BFA&year=2012|2019&year_where=BETWEEN")), 

    #"Converted to Table" = Record.ToTable(Source), 

    #"Filtered Rows" = Table.SelectRows(#"Converted to Table", each ([Name] = "data")), 

    #"Removed Columns" = Table.RemoveColumns(#"Filtered Rows",{"Name"}), 

    #"Expanded Value" = Table.ExpandListColumn(#"Removed Columns", "Value"), 

    #"Expanded Value1" = Table.ExpandRecordColumn(#"Expanded Value", "Value", {"data_id", "iso", "event_id_cnty", "event_id_no_cnty", "event_date", "year", 
"time_precision", "event_type", "sub_event_type", "actor1", "assoc_actor_1", "inter1", "actor2", "assoc_actor_2", "inter2", "interaction", "region", "country", "admin1", 
"admin2", "admin3", "location", "latitude", "longitude", "geo_precision", "source", "source_scale", "notes", "fatalities", "timestamp", "iso3"}, {"data_id", "iso", 
"event_id_cnty", "event_id_no_cnty", "event_date", "year", "time_precision", "event_type", "sub_event_type", "actor1", "assoc_actor_1", "inter1", "actor2", 
"assoc_actor_2", "inter2", "interaction", "region", "country", "admin1", "admin2", "admin3", "location", "latitude", "longitude", "geo_precision", "source", "source_scale", 
"notes", "fatalities", "timestamp", "iso3"}) 

in 

    #"Expanded Value1") 

 

2. Using the above function to collect data of certain country(s): 

o Open Blank Query again → Create a list of countries → Convert it to table and name it. 

o Add a custom column then call the function you just created fnGet_Ctry and apply the parameter to the 
function (ISO3) then expand to see all columns retrieved  

o Expand  

Below is the script that can be used: 

let 

    Source = {"BFA","MLI","NER"}, 

https://www.acleddata.com/
https://www.acleddata.com/wp-content/uploads/2013/12/API-User-Guide-August-2017.pdf
https://www.acleddata.com/wp-content/uploads/2013/12/API-User-Guide-August-2017.pdf
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    #"Converted to Table" = Table.FromList(Source, Splitter.SplitByNothing(), null, null, ExtraValues.Error), 

    #"Renamed Columns" = Table.RenameColumns(#"Converted to Table",{{"Column1", "iso3_id"}}), 

    #"Added Custom" = Table.AddColumn(#"Renamed Columns", "Custom", each fnGet_Ctry([iso3_id])), 

    #"Expanded Custom" = Table.ExpandTableColumn(#"Added Custom", "Custom", {"data_id", "iso", "event_id_cnty", "event_id_no_cnty", "event_date", "year", 
"time_precision", "event_type", "sub_event_type", "actor1", "assoc_actor_1", "inter1", "actor2", "assoc_actor_2", "inter2", "interaction", "region", "country", "admin1", 
"admin2", "admin3", "location", "latitude", "longitude", "geo_precision", "source", "source_scale", "notes", "fatalities", "timestamp", "iso3"}, {"data_id", "iso", 
"event_id_cnty", "event_id_no_cnty", "event_date", "year", "time_precision", "event_type", "sub_event_type", "actor1", "assoc_actor_1", "inter1", "actor2", 
"assoc_actor_2", "inter2", "interaction", "region", "country", "admin1", "admin2", "admin3", "location", "latitude", "longitude", "geo_precision", "source", "source_scale", 
"notes", "fatalities", "timestamp", "iso3"}), 

    #"Removed Columns" = Table.RemoveColumns(#"Expanded Custom",{"iso3_id"}), 

    #"Filtered Rows" = Table.SelectRows(#"Removed Columns", each ([admin1] <> "Agadez" and [admin1] <> "Diffa" and [admin1] <> "Dosso" and [admin1] <> 
"Maradi" and [admin1] <> "Niamey" and [admin1] <> "Zinder")), 

    #"Changed Type" = Table.TransformColumnTypes(#"Filtered Rows",{{"event_date", type date}, {"fatalities", Int64.Type}}) 

in 

    #"Changed Type" 

 

3. See below sample results which you could update regularly and automatically: 

 

 

 

  



 
OCHA | 20 of 28 

 

United Nations Office for the Coordination of Humanitarian Affairs 
www.unocha.org 

Preparing the environment 

1. To easily use the below steps, it will be good practice to store the latest clusters data in the same location, 

together with the master excel file that will be used to process these data using Power Query as shown in 

the below screenshot. 

 

2. Path to data sources (i.e. 3W clusters dataset) 

 

 

3. Create custom function that will accept the directory path as input and generate list of files as its output.  
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4. Create another custom query that will run the previous function by passing the directory path and listing the files 
automatically. You should see list of files as displayed at the bottom of this screenshot. 
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5. Select the dataset you would like to process,  

Note: It’s highly recommended to have your dataset defined in tables in excel. 
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Sharing Power Query Queries Between Excel Workbooks 

1. Copy the query you would want to use from the original file and paste it in the blank sheet or in the workbook you 
want to use it in. 

 

 

Note: If you selected and copied one query, it will copy not only the copied query but also all queries that are called by 
that specific query. 

 

  



 
OCHA | 25 of 28 

 

United Nations Office for the Coordination of Humanitarian Affairs 
www.unocha.org 

      If you had copied and pasted the query to be used in different sheet and you got exclamation mark, it means the 
query will not run properly. Here are the things which should be updated in the pasted query (from Advanced Editor 
screen): 

- Data sources is same or updated to the new location/data 

- Tables and Column names are the same or should be updated to the new ones.  

              

 A brilliant golden secret about power query is to think about shareability while developing it, 
so fewer changes are needed. 
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Power Query Examples 
 

3W including cash activities – download PQ_Sample1 
 

Steps – can vary from one dataset to another but these are the main operations: 

1. Prepare the individual clusters dataset: 

o Add HXLated row for the 3W header in all clusters/sectors datasets (directly under the column headers). 

o Select the 3W raw dataset and create table of your dataset and name it Tbl_3W_WASH, 
Tbl_3W_Nutrition, …etc. 

o Add all recent 3W dataset in one folder 

2. Create new excel file (Consolidated 3W Template)– which will be used to consolidate clusters data: 

o Consolidated_3W sheet: blank sheet which will have the final consolidated dataset added. 

o Admin_List sheet: which can be used to Merge with the consolidated Consolidated_3W to get P-codes…etc. 

o Vocabularies sheet: needs to be updated constantly with new organizations spelled differently, using 
vocabulary helps to create unique names across dataset and avoid duplications. 

o Datasource sheet: this sheet has automatic values added in the cells that will be used to get the files 
location. 

The fours sheets look like the below screenshots: 

 

3. For each cluster: 

o Import/get data (as connection not to import the whole dataset): 

- Option 1: using the path obtained automatically in the Datasource sheet. See Preparing the 
environment section. 

- Option 2: for each cluster data go to Data tab →  Get data → From File → From Workbook or   

o Process the data of each cluster separately: 
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- Promote the HXL row to become the table header 

- Change data type of all column to number, text or date as appropriate. i.e columns for 
Admin_names1,2,3,4 as Text, and reached_beneficiaries to number and same should be done for 
all other columns 

- Merge the cluster data with predefined set of vocabularies/standard names i.e. organizations, 
implementing partners.  

• Example1: voc_beneficiaries_type with first column has original value and the second with 
the categorized values of beneficiaries. i.e. records with values idp_conflict, 
idp_natural_disaster would be categorized as IDPs. 

• Example2: Voc_modality with first column has original values and the second with the 
standard correct values. i.e. mobile_cash, e_cash would be categorized as Mobile money. 

- Merge with admin lists including P-codes at the most granular level   

- Create categories as needed i.e. Modalities, Activity types: 

• Merge/link voc_modality to the Master table using a key of original values so that they 
match to get the standard modality names added to the Master table. 

• Merge/link voc_beneficiaries_type to the Master table using a key of original values so that 
they match to get the beneficiaries categories added to the Master table. 

• You will need to expand the newly merged/linked table to be able to see the columns in the 
Master table. 

- Create calculated fields i.e. apply calculation as defined by cluster methodology for calculating the 
number of beneficiaries; calculate total individual beneficiaries from total household reached (create 

a custom column and its values would be the [total_households_reached]*[avg_family_size]). 

- Keep required columns, and delete the other unnecessary columns. i.e. remove unnecessary 

columns (columns won’t be removed from the original table but only from the query or the 
connection). In many cases, there are data collected that won’t be used for specific type of analysis. 
i.e. Activity ID, descriptions…etc. and only keep columns that will be used in the analysis. These 
columns will not be deleted from the original file, but it will only apply to the query and you could 
revert changes anytime even after closing the file by deleting unwanted steps. 

- Split columns by Delimiter: i.e. split the date column by separator “\” to get it in separate columns for 
the day, month and year. 

4. Combined clusters data in one table. If HXL is properly named, the data will automatically be merged in order. 
Resulting should look like displayed in this screenshot: 



 
OCHA | 28 of 28 

 

United Nations Office for the Coordination of Humanitarian Affairs 
www.unocha.org 

 

5. Add steps to apply to the resulting master table that has all clusters clean dataset consoldiated. 

o Rename columns. i.e replace the HXL names with meaning full names i.e. #adm1 +name to be 
Admin1_Name…etc. 

o Unpivot columns, I.e. unpivoting columns of reach beneficiaries disaggregated by age and gender 
(beneficiaries_boys, beneficiaries_girls, beneficiaries_mens, beneficiaries_women) to add two new columns: 

- One column is called attributes and its data would be for example (beneficiaries_boys, 
beneficiaries_girls, beneficiaries_mens, beneficiaries_women). 

- Another column is called values and its data would be the actual values of each attribute. 

 

 


