
POWERBI
The PowerBI program is used to create interactive visualizations and 
business intelligence reports. It could be used for product automation 
and exploratory data analysis. 
 
In this tutorial, we will learn the basics of PowerBI to create an interactive 
OCHA 3W product from start to finish. 
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SETTINGS AND WORKSPACE

Workspace overview

Open the PowerBI application. By default, PowerBI 
will open to a screen that looks similar to the 
image below. If you have not signed in previously, 
it will ask you to use your UN email address and 
password.

A brief description of each section:

•	 Menu ribbons contain most of the document-
wide functionsthat’s needed.

•	 Views sections allows different ways to view 
and edit data.

•	 Canvas is where the report is shown.

•	 Panes are the tools that construct the report.

Panes

Menu

Views Canvas
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LAYOUT

Create a new document using an OCHA template

For a quick start, there is a pre-made OCHA 
template containing a banner, footer, grid, and 
colour swatches. 

To create a new document using the template, click 
File > Import > Power BI template. 

Browse to  exercise\2019_OCHA_PowerBI_A4_
template.pbit and click Open

The template should look like this:

If the panels are fully expanded, close them by 
clicking the right arrow icons 

The file is still untitled. Go to File > Save As and 
give it the filename OCHA-Caribbean-3W-2017  
with a .pbix extension. Save it in the same folder.
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The report will only be one page so delete the 
second page by right-clicking its tab and 
choosing “Delete Page”.

Right-click the “Landscape” tab and rename it 
“Overview”.

Grid

A grid will help create a proportional structure that 
brings clarity, order, consistency, and harmony 
to your design.  The OCHA template provides a 
12-column grid design in Cyan. 

The grid is created by adding 
a background image to the 
canvas. Darken or lighten it 
by adjusting its opacity. Click 
anywhere on the canvas and 
select the Format tab in the 
Visualizations pane. Got to the 
“Page Background” section and 
increase opacity to 50% to 
make it lighter.
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TEXT

Edit template text boxes

The template header has three text fields. To edit, 
hover the mouse over the text then click and type.

•	 replace COUNTRY NAME with CARIBBEAN 
HURRICANES

•	 replace Sub-title with Who’s doing, What, 
Where (3W)

•	 replace as of XX Mmm YYYY with as of 10 Oct 
2017

The template footer has text as well but it’s just one 
text box. 

•	 change the Creation date field info with 5 Oct 
2017

•	 change the Sources field info with CDEMA, 
Humanitarian Partners

Creating text boxes

To create text boxes click the  button in 
the Home menu tab

A text box will pop-up. Use the settings in the 
screenshot below for the section title text.

To move the text box, make sure the tip of the 
mouse pointer is right on the the text box border 
then click and drag. Place the text box in the top left 
corner of the grid.

Copy and paste

Copy (Ctrl+C) and paste (Ctrl+V) and edit the text 
to create three more titles as shown below

Multiple select

To select multiple items hold down CTRL while 
clicking objects.

Alignment

Align the text boxes to their tops by multiple 
selecting them and then go to the format tab and 
press the align button. Choose “Align top”

Use #333333 or 
“black, 20% lighter” 
for all blacks on the 
product
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LINES

Add section title lines

Lines under the titles 
should be added to better 
distinguish the sections. To 
add a line go to the Home 
tab and look for the 
Shapes button and select 
Line.

This will add a line but it 
will be vertical. Use these 
setttings to create a black, 
horizontal, 2 pt line and 
place it below the section 
title text.

It should look like this:

Make sure there’s some white space between 
the text and line. Use the arrow buttons on the 
keyboard to nudge the line into position.

Create 3 more lines for the other sections like 
below:

Make sure they are aligned like the text. Note the 
different column widths of each section:

•	 Overview: 2 columns

•	 Who, What: 3 columns

•	 Where: 4 columns

Add section divider lines

Line dividers separating 
each section vertically 
is needed. Follow these 
settings after creating a 
line. 

Make sure the lines 
extend from the top to 
the bottom of the grid 
and it is centered within 
the gutters. Create two 
more copies to divide the 
other sections. It should 
look like below:
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OVERVIEW TEXT

Create a text box to hold the overview text and 
follow these settings:

Copy and paste this text into the box:

The 2017 hurricane season has caused 
unprecedented levels of destruction across the 
Caribbean. Hurricanes Irma, Jose, and Maria has 
devastated the lives of millions of people, and 
left hundreds of thousands of people homeless 
and displaced. This dashboard aims to track 
humanitarian actors in the region to help 
coordinate response efforts.
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DATA

Importing the main data set

To import data into PowerBI click the Get Data 
button in the Home tab and select your data format. 

In this case, the data is in CSV format. Browse to  
 exercise\CDEMA-3W.csv and click Open

A screen will popup showing the data being 
imported. Click Load to finish the process.

Fields pane

Expand the Fields 
pane, the data fields  
imported from the 
CSV should now be 
visible.
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Data view

Go into data view by pressing the Data button 
on the left sidebar .  This shows all the data  
uploaded.

Importing another data set

Using the same steps as importing the main data 
set, import the spreadsheet containing cluster 
icons information. Keep in mind that this new file 
is in Excel format. The file is located at  exercise\
cluster-icons.xlsx

Go into data view  and choose your table in the 
Fields menu on the right.  Sometimes, you’ll get 
situations like below where the first row is not 
treated as your table headers.
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Model view

Model view enables 
establishing relationships 
between tables. To go into 
model view, press the 
Model button on the left 
sidebar .  

To fix:

1. Click on Edit Queries

2. Select Cluster Icons

3. Click Use First Row as 
Headers
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Defining table relationships

A relationship between 
tables means having a field 
in both, containing the same 
data, which allows them to 
be linked. In this case, the 
“Sector” field in CDEMA-
3W and the “Cluster” field 
in Cluster Icons need to be 
linked. Both fields should 
have matching sector/cluster 
names so if a cluster icon 
is needed, this relationship 
allows its retrieval.

To establish the relationship, 
click and drag the Sector 
field to the Cluster field. A 
line connecting the tables 
should form.
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SLICERS
Slicers allows filtering by categories within the 
report. It is useful when trying to find categorized 
information quickly. In the Visualizations pane, 
there’s a slicer visual included but we want ours 
to be more visual so we will install the “Chiclet 
Slicer” from the Marketplace.

Follow the red boxes and lines to learn how to 
import from the marketplace



13

Now, switch to the 
formatting pane. Use 
the following settings:

General

•	 Columns: 2

Header: Off

Chiclets

•	 Text size: 8

•	 Height: 53

•	 Width: 93

•	 Selected colour:  #B3D2F2

•	 Hover colour:  #B3D2F2

•	 Disabled colour:  #E6E6E6

•	 Outline colour:  #E6E6E6

•	 Outline weight: 1

Position 
and resize 
the tile 
below the 
overview 
text and it 
should look 
like this. 
Make sure 
its left, right, 
and bottom 
is lined up 
with the 
gridlines.

SLICER SETUP
While the newly created slicer is selected, drag 
fields on the right to the sections on the left as 
shown below:
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The built-in labels for the tiles won’t be used for 
this exercise since customization is limited. Instead, 
create a text box above the slicer using the settings 
below.

Object layering

Using this method, eventually there will be tile 
overlaps and it will be hard to select certain things. 
If you select a tile, the Format tab will activate and 
the layering order can be adjusted.

KEY FIGURES
Key Figures are staples of OCHA products. In this 
section, a key figure visual that looks like this will 
be created:

1.	 To add the icon, click  button in the 
menu. 

2.	 Choose exercise\icons\building.png. 

3.	 Place it below the WHO section and try to line 
its top with the overview text on the left. 

4.	 Resize so it’s about the same height as three 
lines of overview text.

Next, add the big blue figure:

1.	 Install, the Advanced Card   custom visual 
from the marketplace

2.	 Click on it in the Visualizations pane

3.	 Drag ‘Organization Code’ to the ‘Data Field’

4.	 In the field dropdown–, choose ‘Count 
(Distinct)’
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Now switch to the formatting pane and use the 
following settings. (Note that colours that were 
used previously could be accessed in the colour 
picker menu under the “Recently colors” section):

General

•	 Alignment: left-align

Data Label

•	 Colour: #418FDE 

•	 Font-size: 50

•	 Font-family: Arial

•	 Bold:  On

Category: Off

Visual Header: Off

Position and resize it next to the building icon, 
making sure it is the same height. Add a text 
label next to it (Arial, 16pt, black). It should look 
like this:

Do this two more times for the ‘What’ and ‘Where’ 
sections but don’t start from scratch. Copy and 
Paste the figure and label to avoid re-doing all the 
steps. Follow the settings for the other sections:

‘What’ section

•	 Data field: Sector

•	 Icon: Multi-cluster-sector.png 

•	 Text label: Sectors

‘Where’ section

•	 Data field: Country

•	 Icon: Location.png 

•	 Text label: Sectors

Make sure they all line up horizontally. It should 
look like this:

At this point, the product should look like this:
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Switch to the 
formatting pane and 
use the following 
settings:

Y-axis

•	 Colour: #333333

•	 Font-family: Arial

•	 Text size: 9

•	 Max size: 35

•	 Inner padding:  25

•	 Title:  off

X-axis: off

Data labels

•	 Colour: #418FDE

•	 Text size: 9

•	 Font-family: Arial

Position 
and resize 
the tile 
below the 
‘WHO’ 
key figure 
and put a 
label above 
it  like we 
did for the 
chiclet 
slicer. 
Should look 
like this.

BAR CHARTS
Create a simple bar chart by clicking on the’ Stacked 
Bar Chart’   visual. Then, drag the fields shown 
below:
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Filtering

You’ll notice that the 3rd bar chart value is missing 
a label. It’s most likely because those cells were left 
blank. In some cases, hiding certain values from 
appearing in your chart or page is necessary. That’s 
where filtering can help.

This is needed one more time for the ‘What’ 
sections. Copy and Paste the chart and the title to 
avoid re-doing all the steps. Follow the settings for 
the other section:

•	 Axis: Sector

•	 Value: Count of Sector

•	 Title: # of locations per sector

Your canvas should now look like this:

1.	 With the chart selected, expand the Filters pane

2.	 Expand ‘Organisation Code’

3.	 Check ‘Select All’

4.	 Uncheck the empty row
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We’ll need to do this one more times for the ‘What’ 
sections. Copy and Paste the chart and the title to 
avoid re-doing all the steps. Use these settings:

•	 Legend: Emergency Response

•	 Values: Count of Organization Code

•	 Title: % of orgs doing emergency response

Your canvas should now look like this:

Now we switch to 
the formatting pane 
and use the following 
settings:

Data colours

•	 Colour: Pick the OCHA blues

Detail labels

•	 Font-family: Arial

Title: off

Visual header: off

Position and resize the tile below the ‘WHO’ bar 
chart and put a label above it like we did for the bar 
chart. Should look like this:

PIE CHARTS
Create a simple pie chart by clicking on the ‘Pie 
chart’    visual. Then drag the fields shown below:

The data received isn’t 100% clean so you should 
use filters for now. Select Donor, Red Cross, 
Government, NGO, and UN agency. 
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MAPPING
For mapping purposes, use the Mapbox Visual 
custom visual to load a custom basemap that use 
standard UNGIS boundaries.

1.	 Install the Mapbox Visual   custom visual 
from the marketplace

2.	 Click  in the Visualizations pane

3.	 Follow the settings to the right. Note that the 
tooltip is using ‘Organisation Code’ but was 
renamed in the Tooltips section.

Now, switch to the formatting pane and use the following settings:

Viz Settings

•	 Access Token: pk.eyJ1IjoicmVsaWVmd2ViIiwiYSI6IldYR2ZuV3cifQ.eSPZMZWE6UyLtO0OH_-qrw

•	 Map Style: Custom

•	 Style URL: mapbox://styles/reliefweb/cjyh975uc16641cqv12fi1rz6

Geocoder: off

Circle

•	 Radius: 5

•	 Min, Max, Highlight Color: # 418FDE

•	 Opacity: 50

•	 Stroke width: 0

•	 Legend: off

Everything else: off

Position and resize the tile below the ‘WHERE’ key figure.  Make sure to stay within the grid.
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The canvas should now look like this:
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BOOKMARKS
PowerBI let’s you save a state of a report based on 
what filters were selected. In this case, the default 
unfiltered state of the report will be saved as a 
bookmark so it could be used to reset the interface.

Click the View tab and check the Bookmarks 
Pane box.

The Bookmarks pane should now be visible. Make 
sure no filters are selected and press the Add 
button.  A “Bookmarks 1” button will be added but 
right-click that and rename it “Home”.

 

Now, anytime you want to go back to this or any 
view, you just select its bookmark. The bookmark 
just created will be used in the next section, where 
it will be the linked to a button as an action.
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Outline: 

•	 Outline color: #418FDE

•	 Outline weight: 3

•	 Round edges: 3

Fill: 

•	 Fill color: #418FDE

Title: off

Visual header: off

Action: 

•	 Type: Bookmark

•	 Bookmark: Home

•	 Tooltip: Reset the entire page

Position and resize the button at the top right 
corner of the header. It should look like this:

BUTTONS
Create a ‘Reset’ button so the audience can always 
go back to the product’s original state.

Click ‘Buttons’ in the menu and select ‘Reset’

Switch to the formatting pane and use the 
following settings:

Button text: 

•	 Button text: Reset

•	 Font color: White

•	 Padding: 16

•	 Text size: 12

•	 Font family: Arial

Icon: 

•	 Padding: 7px

•	 Line color: White

•	 Weight: 2
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REPLACING THE DATA
If data changes, replace it in PowerBI and the 
graphics will automatically update as long as the 
fields are the same. 

Go to File > Options and settings > Data source 
settings. 

Highlight one of your data sets and change its 
source.

PUBLISHING
Before publishing, don’t forget to save the 
document and hide the guides.

There are many ways to save which inlcude the 
following:

•	 Saving as a PDF and submitting to ReliefWeb

•	 Embedding to a platform

•	 Sharing a web link

PDF

Go to File > Export to PDF

Embedding or Web link

Click the Publish button  and choose a 
workspace.

Follow the open link:

 

Choose from the options. You might be restricted 
based on account level (Pro vs Non-pro).
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CONGRATS!
You finished the tutorial! The final output should look like this:

For questions or comments, email: victorino@un.org


