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	Excel Basics for OCHA IMOs
Using Excel 2010
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Excel is an incredibly powerful tool and basic proficiency is critical for all OCHA IMOs.  Excel is used by OCHA IMOs in data collection, processing, analysis and in the creation of graphics for dissemination of information. This guide identifies the most commonly used functions, formulas and add-ins used by an OCHA IMO.  There is extensive guidance material and videos available on the internet for those who need greater explanation or would like to dive into the more advanced skills.  
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So you think you are good at Excel
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[bookmark: _Toc443643596][bookmark: _Toc445112500]Resources and Links
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https://www.youtube.com/user/ExcelIsFun
YouTube channel with 2,500 how to videos with a wide range of excel tutorials from beginner to advanced
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http://www.exceltraining101.com/
Simple easy to follow instructions and videos on a wide range of excel basics
[bookmark: _Toc443643597][bookmark: _GoBack]

[bookmark: _Toc445112501]How to work in Excel
Excel functions and capabilities are truly powerful but to take full advantage of the program data should be organized and a clear approach to processing your data should be followed. 
	Step 1 – Review: Before doing anything review the spreadsheet.  Ask critical questions – does this make sense?  Are the totals from formulas?  Are there hidden rows, columns or sheets?  Did they use proper codes and names?  How old is the data?  Is if from a reliable/trusted source?   What does this data mean? What does this data not mean?  Look with a critical eye, if something does not make sense contact the sender.

	[image: ]Step 2 – Create:  Sometimes spreadsheets sent by partners are a bit …messy.  To do professional analysis you need to first create an Excel workbook that is clean, documented, and easy to understand.  Start with a new workbook and name and color code the worksheets 

	Step 3 – Clean:  Copy the original data into the “clean” worksheet using “paste values” (under paste special).  This will remove all formatting (be careful with merge cells).  Look for hidden rows, columns, totals that don’t add and do a count of your records – use this count thought out the cycle to make sure you have not made any errors.  
Don’t rush this step – find and fix errors.

	Step 4 Processing:  The data is starting to take shape!  Take your clean data and make an Excel Table then use filters to check for duplicates, text in number cells (or vice versa) or other data inconsistencies.  Don’t rush this step either, finding and fixing problems now will save you hours and potential embarrassment later.

	Step 5 – Analyze: Now the fun begins!  Explore your data, take your Excel Table and create a pivot or start using power queries, slice your data.  Remember even if you did a fantastic job cleaning and processing please keep doing “logic” checks the data might still have errors and always double check counts and totals.

	Step 6 Present:  WooHoo! Now you start to create beautiful (remember to keep it simple and OCHA blue is RGB: R:2 | G:108 | B:182), easy to read tables, charts, and graphs.  Please don’t forget to check your totals and always ask ‘Does this make sense??” – you don’t want all your hard work discounted due to a simple error.























[bookmark: _Toc445112502]Drop Down List
Drop-down lists in Excel are helpful if you want to be sure that users select an item from a list, instead of typing their own values.  This is most useful when creating templates for 3W or other data collection activities.  Normally it is best to create a new worksheet with all of your lists (admin names, organization names, etc) and then hide this worksheet so that it cannot be easily changed.
	1
	In a new worksheet, type the names of governorates you want to appear in the drop-down list. 
Highlight all the cells and give this range a name, ‘Governorates’ in the name box 
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	2
	On the first sheet, select cell C3.
On the Data tab, click Data Validation 
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	3
	Click Data Validation, the 'Data Validation' dialog box appears.
In the Allow box, click List.
Click in the Source box and type Governorates, and hit 
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	4
	RESULT: 
	[image: ]



For dependent or cascading drop down list see - http://excelsemipro.com/2011/05/a-dynamic-dependent-drop-down-list-in-excel/ 
 
[bookmark: _Toc443643598][bookmark: _Toc445112503]Pivot Tables
Pivot tables are a powerful feature of MS Excel. It offers a fast and powerful way to analyze numerical data, particularly if your data frequently changes. If you are finding yourself writing formulas to summarize data in Excel (using functions such as SUMIF and COUNTIF) then Pivot Tables can save you time and work and give insights into your data that are otherwise too hard to discover. Not only that, but they also allow you to quickly change how your data is summarized with almost no effort at all.  
	1
	Perfect your data source: 
To minimize problems down the road, always use good quality source data, organized in a tabular layout. "Perfect" source data will have:
no blank rows or columns, and no subtotals 
Each column will have a unique name (on one row only)
Every field will have a value in every row, and
Columns will not hold repeated groups of data (i.e. month names, location names, region names, etc.). 
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	2
	To insert a pivot table: 
Click on any single cell inside the data set. 
On the Insert tab of the ribbon, click the PivotTable button.
In the Create PivotTable dialog box, check the data range and click OK 
	[image: ]

	3
	Pivot table structure 
PivotTable Field List – this section in the top right displays the fields in your spreadsheet. You may check a field or drag it to a quadrant in the lower part.
The lower right quadrants – this area defines where and how the data shows on your pivot table. You can have a field show in either a column or row. You may also indicate if the information should be counted, summed, averaged, filtered and so on. 
The area to the left is the result of your selections from above.
	[image: ]

	4
	‘Count’ the data first: 
When you first create a pivot table, use it to generate a simple count first to make sure the pivot table is processing the data as you expect. 
To do this:
Simply add any text field as a Value field. You'll see a very small pivot table that displays the total record count, that is, the total number of rows in your data. 
	[image: ]

	5
	Change layout of Pivot table: 
When you create a new Pivot table, it is in Compact Layout by default. You can change to Outline or Tabluar layout.
Select a cell in the pivot table. 
On the Ribbon, under the PivotTable Tools tab, click the Design tab,
At the left, in the Layout group, click the Report Layout command. 
Click the layout that you want to use, e.g. Show in Tabular Form, the pivot table will change to the selected layout.
	[image: ]

	6
	Summarize values as: 
When you add a field to the pivot table's Values area, 11 different functions, such as Sum, Count and Average, are available to summarize the data. When you add a numerical field to the pivot table's Values area, Sum or Count will be the default summary function. To select a different summary function:
Right-click on a cell in the Value field that you want to change;
In the pop-up menu, click Summarize Values By;
Click on the Summary Function that you want to use:
· Sum totals all the underlying values for each item in the field. 
· Count is the default summary function when fields with nonnumeric or blank cells are added to the Values area.
· Average totals all the underlying values in the Values area, and it divides by the number of values.
· Max maximum value from the underlying values in the Values area.
· Min minimum value from the underlying values in the Values area.
· Product result of multiplying all the underlying values in the Values area.
· Count Numbers counts all the underlying numbers in the Values area. 
	[image: ]

	7
	Format all value fields: 
You can format the numeric or text data values in the pivot table by:
Right clicking on any value and;
Select ‘Value Field settings…’. 
Apply the appropriate format.
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	8
	Show values as percentage: 
Right-click the IDPs Families field, and;
set "Show Values As" to "% of Grand Total"; 
Please refer to figures 8 and 9 below;
You can drop a field as many times as you want to show the values in different formats. 
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	9
	Rename field names: 
You can rename field names or headers in your pivot table by simply overwriting the default name with your name. 
When you try to rename fields, you might run into a problem if you try to use exactly the same field name that appears in the data, excel complains that the field already exists, and throws a "PivotTable field name already exists" error message. 
TIP: To overcome that error, simply add a space to the end of your new field name.
	[image: ]

	10
	Manually group a pivot table: 
You can group field data manually.
Control-click to select each item in the first group, 
Then right-click one of the items and choose Group from the menu
Excel creates a new group, "Group1". 
You can rename "Group1” to a meaningful name.
	[image: ]

	11
	Group numeric data into ranges: 
You can also group numeric data, whether in your rows or columns of the pivot table, in to ranges or buckets.
Drop ‘IDPs families’ field on the Rows labels and;
Drop “governorate’ field in the Column labels. 
Right click anywhere on the IDPs families values and select ‘Group…’ from the options, click OK. 
Drop the ‘IDPs families’ again in the ‘Values’ (make sure summarize values as count) is selected. 
The final table should look like - 
	[image: ]
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	12
	Duplicate or clone a pivot table: 
You can duplicate a pivot table by either duplicating the worksheet in which your pivot table was originally created (Ctrl + drag with left mouse click) or simply copy paste the pivot table on another sheet.
	1- Copy the worksheet with the pivot table

	13
	Format empty cells in pivot table: 
If you have a pivot table that has a lot of blank cells or if there are #Div or N/A errors, you can control the character that is displayed in each cell. 
To set your own character, right-click inside the pivot table and select Pivot Table options. 
Then make sure that "Fore cells show:" and “For error values show:” are checked;
and enter the character you want to see.
	

	14
	Pivot Charts: 
A pivot chart is the visual representation of a pivot table in Excel. Pivot charts and pivot tables are connected with each other. To insert a pivot chart, 
click any cell inside the pivot table;
on the Insert tab, click Column and;
 select one of the subtypes. For example, Column chart. 
You can always change the chart type and its design and layout in the ‘Design’ and ‘Layout’ tabs at the top.
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	15
	Slicers: 
One of the nice things about slicers, compared to report filters, is that they can control multiple pivot tables or charts.  This makes them very useful for building dashboards that are based on pivot tables.
a) We created a simple pivot table earlier, that shows IDPs families by governorate / district.  Duplicate the pivot table, and set the second table to show IDP individuals by governorate / district 






b) Add a slicer to filter by ‘Governorate’ 
c) Note:  at this point, the slicer controls only one pivot table. 

d) In many cases, if you present more than one pivot table, with one slicer, you'll want the slicer to control the pivot tables that are based on the same data. All slicers have a setting that links them to pivot tables, called "Pivot Table Connections".


e) You can access this setting using the button on the Slicer Tools tab of the ribbon. Or, you can right-click and select from the context menu.
f) Once you have the Pivot Table Connections dialog open, you'll see a list of the pivot tables in the workbook.
g) The pivot table currently controlled by the slicer will be checked. Just check the checkbox for each pivot table you want to control and click OK. 



h) Now you can see that see that selected governorate in these two pivot tables match, and the slicer is controlling both.
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	16
	Calculated Fields: 
You can create a new field that performs a calculation on the sum of other pivot fields. For calculated fields, the individual amounts in the other fields are summed, and then the calculation is performed on the total amount.
Calculated fields are automatically available in all pivot tables that are based on the same pivot cache.
To add a calculated field, select a cell in the pivot table; 
On the Excel Ribbon, click the Options tab. 
In the Calculations group, click Fields, Items, & Sets, and then click Calculated Field.
In the ‘name’ field give it a name ‘IDP Inds’. 
In Formula type the following: ='IDPs Families' * 6. 
Click Add and OK. Here we are calculating the total IDP numbers by multiplying IDPs families number with 6. 
Limitations:
1) Calculated field formulas cannot refer to the pivot table totals or subtotals;
2) Calculated field formulas cannot refer to worksheet cells by address or by name.
	[image: ]
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	17
	Custom calculations: 
Use custom calculations in a pivot table, to summarize the data, by using the values in other cells in the Values area.
a) Difference From: use the ‘Difference From’ custom calculation to subtract one pivot table value from another, and show the result. Let’s calculate each district’s IDPs Families difference to the previous district. 
Right-click one of the IDPs Families value cells, and click Show Values As, Click Difference From. 
In the Show Values As dialog box, from the Base field list, choose District. This is the field that we want to use for comparing the IDP families numbers. 
From the Base item list, choose (previous). Within the ‘IDPs families’ field, we want to subtract one district IDPs from the previous district.









b) % of Column Total: In our pivot table (figure 29), we have Governorate and District in the Rows area and IDPs families in the Values area. A custom calculation will be added, to show the percentage for each district's IDPs, compared to the governorate total. 
Right-click one of the IDPs families value cells, and 
Click Show Values As> Click % of Column Total. 
The field changes, to show the percentage that each district's IDPs Families contribute to the overall governorate total.
c) % of Row Total: In our pivot table (figure 30), we have Governorates in the Rows area and IDPs families, grouped in range of 1000s, in the Columns area and IDPs Families numbers in the Values Area. 
Right-click one of the IDPs Families value cells, and 
click Show Values As > Click % of Row Total. 
The field changes, to show the percentage that each bucket contribute to the Governorate’s overall IDP families number. 
For example in Dahuk, about 32% of the IDPs Families are in the 1-1,000 range. Overall, 33% of the IDPs families are in 1-1,000 range.
d) % of Grand Total: In our pivot table, we have Governorates in the Rows area and IDPs families, grouped in range of 1000s, in the Columns area and IDPs Families numbers in the Values Area. 
Right-click one of the IDPs Families value cells, and 
click Show Values As > Click % of Grand Total. 
The field changes, to show the percentage that each item contribute to the Grand Total. 
For example in Dahuk, about 18% of the IDPs Families are in the 1-1,000 range. Overall, 94% of the IDPs families are in 1-1,000 range.
	

[image: ]

[image: ]

[image: ]





[image: ]







[image: ]

	18
	Conditional Formatting (CF): 
Conditional formatting when applied to PivotTables is applied to the underlying structure of the PivotTable rather than to the cells themselves. So, when you interact with a PivotTable such as moving fields around and viewing your data in different ways, the formatting is updated as you work.
a) Select a SINGLE cell (C4) on your pivot table IDPs families values, where you want to apply conditional formatting. 
b) Go to Home tab in the ribbon, and click on Conditional Formatting. 
c) Select Top/Bottom rules and then Top 10 items. 
d) Enter ‘5’ in the cell and click OK. This will highlight ‘C4’ cell value









To extend this formatting to the same data for the other districts, with the first range of cells still selected:
a. Click the Formatting Options button which appears at the bottom right of the range;

b. Choose the third option - "Apply formatting rule to ... All cells showing "IDPs Families" values for "District";

c. This applies the formatting to the same data for every other district in the Excel PivotTable without the necessity of applying this to each range individually.

d. If you filter governorates to ‘Baghdad’ and ‘Basrah’ only , you will notice that the CF rule has automatically adjusted and applied to these two governorates only 

e. Similarly, if we have “show all subtotals at bottom of group” options switched on, then we can also apply CF for the sub-totals separately. (See figure 18 to switch on this option and figure 19 as the output of another CF on subtotals only).
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[bookmark: _Toc443643599][bookmark: _Toc445112504]Common Excel Functions 
Below are only some of the many functions available in Excel, those listed below are only some of the ones used most frequently – let us know if we should highlight others.
	1
	COUNTA: This function counts the number of cells that are not empty as well as the number of arguments that contain values.
Syntax: =COUNTA(Value1, Value2…)
Example: =COUNTA(D2:D8)

You would use this 
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	2
	COUNT: This function counts the number of cells that contain numbers as well as the number of arguments that contain numbers.
Syntax: =COUNT(Value1, Value2…)
Example: =COUNT(C2:C8)

	[image: ]

	3
	COUNTIF: This function counts the number of cells in a range, that meets a given criteria.
Syntax: =COUNTIF(range, criteria)
Example: =COUNTIF(C2:C8,">=100")
	[image: ]

	4
	SUMIF: This function adds all numbers in a range of cells, based on a given criteria.
Syntax: = SUMIF(range, criteria, [sum_range])
Example:=SUMIF(A2:A8,"Baghdad",D2:D8)

	[image: ]

	5
	VLOOKUP: This function performs a vertical lookup by searching for a value in the left-most column of the table and returning the value in the same row in the index_number position.
Syntax: = VLOOKUP( lookup_value, table_array, col_index_number, [not exact match or exact match])
Example: =VLOOKUP("Erbil",A2:C8,3,FALSE)
	[image: ]

	6
	AVERAGEIF: This function returns the average (arithmetic mean) of all numbers in a range of cells, based on a given criteria.
Syntax: = AVERAGEIF( range, criteria, [average_range])
Example: =AVERAGEIF(A2:A8,"Anbar",D2:D8)
	[image: ]

	7
	OFFSET: This function returns a reference to a range that is offset a number of rows and columns from another range or cell.
Syntax: =OFFSET( range, rows, columns, [height], [width])
Example: =OFFSET(B1,1,2,1,1)
	[image: ]

	8
	MATCH: This function searches for a value in an array and returns the relative position of that item.
Syntax: MATCH( value, array, [match_type])
Example: =MATCH(60,C2:C8,0)
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	9
	MATCH/INDEX: This function returns either the value or the reference to a value from a table or range.
Syntax: INDEX( array, row_number, [column_number])
Example: =INDEX(B2:B8,MATCH(60,C2:C8,0)) We can use the MATCH function to find the row position in the range C2:C8 to find the row where "60" is located. We then embed this MATCH function within the INDEX function to return the corresponding value in the range B2:B8.
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	10
	LARGE: This function returns the nth largest value from a set of values.
Syntax: LARGE( array, nth_position)
Example: =LARGE(C2:C8,1)
	[image: ]

	11
	IF Function: This function returns one value if the condition is TRUE, or another value if the condition is FALSE.
Syntax: IF( condition, [value_if_true], [value_if_false])
Example: =IF(C2>C3,"Larger","Smaller")
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	12
	Nested IFs: It is possible to nest multiple IF functions within one Excel formula. You can nest up to 7 IF functions to create a complex IF THEN ELSE statement.
Syntax: IF( condition1, value_if_true1, IF( condition2, value_if_true2, value_if_false2 ))
[image: ]Example: =IF(C2>C3,"Larger","Smaller")

	





[bookmark: _Toc443643600][bookmark: _Toc445112505]Excel Tables
Tables allow you to analyze your data in Excel quickly and easily.

	1
	To insert a table, click on any single cell inside the data set.  The go to Insert - Table

	[image: Insert Table]

	2
	Excel automatically selects the data for you. Check 'My table has headers' and click on OK.
Excel creates a nicely formatted table for you. This may still seem like a normal data range to you but many powerful features are now just a click of a button away.
	[image: ]

	3
	To sort a table, click the arrow next to ‘IDPs families’ and click Sort Smallest to Largest.
	[image: ]

	4
	To display a total row at the end of the table, on the Design tab, in the Table Style Options group, check Total Row. 
Click any cell in the last row to calculate the Total (Average, Count, Max, Min, Sum etc.) of a column. 
For example, calculate the sum of the IDP Individuals column.
	[image: ]

	5
	Quick formatting: Excel automatically applies a banded row format to new tables. If you don't like that format, you can choose a new one from 60 predefined formats in the Table Styles gallery on the contextual Design tab.
	

	6
	You can easily extend a table, making data entry much easier. To insert a new record, select any cell in the row below the table's last row and enter a value. Excel will automatically extend the table's formatting to the new row. It also works with columns.
	

	7
	Automatic nomenclature: When entering formulas, you use cell references and range names. When working with a table, Excel works all that out for you. For example in the picture below, instead of displaying C2 in the expression, Excel displays [@[IDPs Families]], the column's name. The table resolves the name automatically; you don't have to do a thing
	[image: ]

	8
	Always visible headers: In a data range, header cells disappear as you scroll, but table headers are always visible.
	

	9
	Formula autofill: When you extend a table to include a new row, it doesn't just extend the formatting but will also copy any formulas.
	

	10
	Dynamic charts: If you base a chart on a table, Excel will update the chart automatically as you change and enter new data into the table.
	





[bookmark: _Toc443643601][bookmark: _Toc445112506]Excel Macro Recorder
Macros in Excel save time by automating tasks that you perform frequently. A macro is a series of commands grouped together that you can run whenever you need to perform the task.
Although you can write your own complex macros in the Visual Basic programming language, the easiest method for creating many macros is to use the macro recorder. When you record a macro, Excel stores information about each step you take as you perform a series of commands. You then run the macro to repeat, or play back, the commands.
	1
	Displaying the Developer tab: The Developer tab provides access to the macro commands, but this tab doesn't appear by default. To display the Developer tab, click the File tab and then click Options, the Excel Options dialog box appears.
Click Customize Ribbon in the left pane, and then select the Developer check box under Main Tabs on the right side of the dialog box. Click OK.
The Developer tab appears in the Ribbon (figure 1).
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	2
	Record a macro: 
Follow these steps to record a macro:
a) Choose Record Macro in the Code group of the Developer tab. The Record Macro dialog box appears.
b) Type a name for the macro in the Macro Name text box.
c) The first character of the macro name must be a letter, and the name cannot contain spaces or cell references.
d) From the Store Macro In drop-down list, select where you want to store the macro: Select , This Workbook; Click OK. 
e) The Record Macro option on the Developer tab changes to Stop Recording.
f) Perform the actions you want to record ( see live demo).
g) Excel records your steps exactly — such as (Select cell C3) — but you can also record the steps relative to any current cell — such as (Go up one row and insert a blank line). To do so, click the Use Relative References button on the Developer tab. You can turn the Use Relative References feature on and off as needed when recording the macro.
h) Choose Stop Recording in the Code group of the Developer tab.
i) The macro recorder stops recording keystrokes and the macro is complete.
	





[bookmark: _Toc445112507]So you think you are good at Excel
All OCHA IMOs should know the following functions and

Review


Create


Clean


Process


Analyze


Present









www.unocha.org
The mission of the United Nations Office for the Coordination of Humanitarian Affairs (OCHA) is to mobilize and coordinate effective and principled humanitarian action in partnership with national and international actors.
Coordination Saves Lives
United Nations Office for the Coordination of Humanitarian Affairs (OCHA)
Coordination Saves Lives | www.unocha.org
image1.emf

image2.png
excelisfun




image3.png
&xcel Training 101

Excel Training to Help You Get Stuff Done




image4.png
Notes GIEIN Clean [ Processing = Analysis





image5.png
Governorates

Missan
Muthanna
Najaf
Ninewa
Qadissiya
salah al-Din
sulaymaniyah
Thi-Qar
|Wassit





image6.png
Data | Review  View  Developer
] Connections K = e :
e T e L= N

Fiter Tedto Remove | Data |Consolidate Whatlf | ¢
o Edit Links % Advanced | Columns Duplicates Validation Alla’tsls"

nections Sort &Filter Data Tools





image7.png
Settings | Input Message | Error Alert

Validation criteria

@ In-cell dmpmmn

Com—c

Source:

[=covemnonates

[] Apply these changes to all other cells with the same settings

(e=m] =]





image8.png
“Anbar
Babylon

Basrah
Dahuk
Diyala
Erbil
Kerbala





image9.png
#1- Tabular Format
(onerow of headers

A
>

Dried Pears

2
3

a v

5 AFTE 88

5 Claromomoer 89

7 Dec:5-2014 _syrup 43 $280.00
8 Dec-82014 _Curry Sauce 29 3480,
9 Dec-8-2014 GreenTea 12 $296.01
10 Dec-8-2014 _ Dried Pears 81 $2,430.00





image10.png
IDPs -

Governorate

District

Location Name

IDP

IDPs

HFa

11 {Anbai
12 {Anbai
1 {anbai
14 !Anbai

Create PivotTable

Choose the data that you want to analyze
(@ Select a table or range
Table/Range: | IDPs
(©) se an external data source

Connection name:

(@ New Worksheet
(© Bxisting Worksheet

Location:

Choose where you want the PivotTable report to be placed

——

15 {Anbar—————ArRuwe———ATTEDaTE 2055230





image11.png
B6 f| 8734
7] S R T
1
2
3 RowLabels| - |Sum of IDPs Families
4 Anbar 14963
5 Babylon 1506
e 27
7 |Basrah 'Sum of IDPs Families|
8 Dahuk Value: 8734
9 Grand Total Row: Baghdad

Choose felds to add to report:

[istrict
[Location Name

[P ndividuals

Drag fields between areas below:

¥ Report Filter

i Column Labels

i Row Labels = Values
Governorate Sum of IDPs




image12.png
298|

Choose felds to add to report:
[JGovernorate

Drag fields between areas below:
¥ ReportFiter  E Column Labels

L JL_ ]

i Row Labels = Values

e




image13.png
d9-c

Row Headers  [[] Banded Rows.

Sebtotal=gGrand) [Slask; Column Headers [] Banded Columns
- Totals - Rows -
PivotTable Style Options |
Show in Compact % 10012000
[clT o TelF] s
Show in Outline

Repeat All Item Labels 60 38 99 68 23 288

2 1 2 s

Do Not Repeat Item Labels ‘I ‘I

9 Grand Total 62 38 100 68 30 298





image14.png
B

anbar
Babyion
Baghad
Basrah
Dabuk. 2525 Number Format,
Grand Total 48,099
Refresh
sort >
X Remoye "Count of IDPs Famil
sum
Count Show vl >
Average Show Details
Max Value Field Settings...
Min PivotTable Options...
Product

Hide Field List





image15.png
1-1000
1001-2000
2001-3000
4001-5000
Grand Total

G2 copy
& Format Cells.

Number Format,
@ Refresh
sort
X Remoye "Count of IDPs Families”

Summarize Values By

Show Values As

‘Show Details

lel. . .





image16.png
G W e

Row Labels -~

Anbar
Babylon
Baghdad

- Basrah

8
9
10
1
12
13

Dahuk
Grand Total

IDPs Families
31.11%
3.13%
18.16%
0.77%}
46.83%
100.00%

[istrict
[Location Name

Drag fields between areas below:
¥ ReportFiter [ Column Labels

f Row Labels = Values

orsromies -




image17.png
G2 copy
& Format Cells.
Number Format,
Refresh
Sort »
X Remoye “Count of First~
Summarize Values By >
(——
Show Detais

Value Field Settings.
PivotTable Options.
Hide Field List

|feds between areas belon:
Report Filter  Column Labels.

No Calculation
9% of Column Total

9% of Row Total

%0f.





image18.png
Row Labels - IDPs Families Sum of IDP Individuals

Anbe calibri - 11 - A A E % s & 89778

B0y m g A w8 903
Bag. = 52404
|Basr * I 2226
'Dah{ = < 135150
Grar 5 Format Cells. 288594
@ Refresh
Sort »
Fiter 3

Subtotal "Governorate”

Expand/Collapse »
G
@ Ungroup.

Move »

X Remoye "Governorate”




image19.png
PivotTable Field List v

Choose felds to add to report:
Colu -~

Row Labels| - | Anbar Babylon Baghdad Basrah | [J0istrict
[Jtocaton tiame

W

Drag fields between areas below:
¥ ReportFiter [ Column Labels

Governorate

f Row Labels = Values

| DPsFamilies v |





image20.png
Count of IDPs Families Govelid
Anbar Babylon Baghdad Basrah Dahuk Grand Total

IDPs Families

1-1000 60 38 9 68 23 288

1001-2000 2 1 2 5

2001-3000 4 4

4001-5000 1 1

Grand Total 62 38] 100] 68 30 208
Count of IDPs Families|

Value: 38

Row: Grand Total
Column: Babylon





image21.png
Anbar

Total IDPs Families

Babylon Baghdad  Basrah

22,525

Dahuk





image22.png
A B C
IDPs Families by District
2314

3 Governorate T District - IDPs Families

4  =Baghdad Abu Ghraib 2,262
5 Adhamia 412
6 Al Resafa 306
7 Kadhimia 899
8 Karkh 737
9 Mada'in 641
10 Mahmoudiya 2,314
11 Tarmia 260
12 Thawra2 903
13 Baghdad Total R 5734
14 Grand Total 8,734
15

16

17 Governorate T District ~ IDP Individuals
18 = Baghdad AbuGhraib 13572
19 Adhamia 2,472
20 Al Resafa 1,836
21 Kadhimia

22 Karkh

23 Mada'in

24 Mahmoudiya

25| Tarmia

28 Grand Total

Abu Ghraib

412 306

Al Resafa

F

899 737 ar

Kadhimia

Baghdad

G

H !

Mahmoudiya

13,572

G
2

IDP Individuals by District

Al Resafa

Kadhimia

13,882

Mahmoudiya





image23.jpeg
PivotTabl

-

out View  Developer  PowerPvot  Acrobat | Options

VofTable Name: Actve Fieh o3 % Grovp Selecion = " B Clear - @ Summar
: o B B =
wotable2 | District * Ungroup i Select 8 Show va
- sont resh Change Data
$ options - | @ Fieldsetings } | B orouprield | &b esh Change D212 | & Move pivotTable | Filds. M
PivotTable Active Field Group| Data | Adions Cala

BS -~ (= : ol




image24.png
A [T ¢

1

2

3 Governorate T District - IDPs Families

1 | =Baghdad Abu Ghraib 2,262
5 | [Adhamia___] 212
5 Al Resafa 306
7 Kadhimia 899
3 Karkh 737
] Mada'in 641
0 Mahmoudiya 2314

[istrict
[Location Name

[1Ps Families
[P ndividuals
[JGovernorate2





image25.png
Governorate 1~ [ £

A B c D E F G H 1
1

> PivotTable Connections (Governorate)
3 Governorate District | - | IDPs Families T e T
4 =Baghdad Abu Ghraib 2262 | 2262 Sheet
5 Adhamia 412

6 Al Resafa 306

7 Kadhimia 899

8 Karkh 737

9 Mada'in 641

0 Mahmoudiya 2314 2

11 Tarmia 260 S

2 Thawra2 903 H

13 Baghdad Total s34

4 Grand Total 8,734

5

6

7 Governorate dividuals,

8 =Baghdad _ 13,572

9 i 2472

0 Al Resafa 1,836

1 Kadhimia -

. b




image26.png
A B C
L
)
3 Governorate T District - IDPs Families
i = Dahuk Amedi 2,913
5 Dahuk 4,184
5 Sumel 15,428
7 Dahuk Total R 22525
3 Grand Total 22,525
)
0
1
2
3
4
5
6
7 Governorate T District - IDP Individuals
8 =Dahuk Amedi
9 Dahuk
0 Sumel
1 Dahuk Total
2 Grand Total
3
4
5
6
7

E F G H ]
1DPs Families by District Governorate ¥
15,428 Anbar
Babylon
Baghdad
Basrah
4,184
2,913 s
Amedi Dahuk Sumel
Dahuk
IDP Individuals by District
92,568
25,108
17478
Amedi Dahuk Sumel

Dahuk





image27.png
K|\ 9= ESA_Excel_Exercise_day_Lxls - Microsoft Exc

PivotTable Tool

Options | Design

pivotTable Name: Active Field: 9 Group Selection | , | = @ Clear - ‘Summarize Values By ~
z =l
PivotTable2 IDPs Families & Ungroup ) select - Show Values As

z| Sort Insert | Refresh Char Data
&S e & Move pivotTable

&3 Group Field Fields, Items, & Sets ~

[ Options - 9y Field Settings.

Slicer=| - Source -

PivotTable | Active Field | Group | Sort & Filter | Data | Actions. | Calculations |
cs ~C fe| 4184

= T T

1 Name: |

2

3 Governorate District| ~ | IDPs Families || "™ J [ oeee

4 ©Dahuk Amedi i

5 Dahuk Felds:

6 Sumel 15,428 || [Governorate B

7 Dahuk Total B 2525 | [ene

8 Grand Total 22,525

9 o

10

1]

2|

13

14|





image28.png




image29.png
Governorate | District| - | IDPs Families IDPs Families Differnece

1
2
3
4 | 5Dahuk Amedi 2,913 ]

5 Dahuk 4,184 1271
& sufDahuk District) lpg 11044
o P— Row: Dahuk - Dahukfae]

8 Grand Total 22,525





image30.png
Governorate T District - IDPs Families IDPs Families Differnece
| =Dahuk Amedi 2,913 1913I
] Dahuk 4,184
] =" 15428
' pal Show Values As (IDPs Families Dﬂ&wﬁu 22525

Gi Calculation: Difference From 22525

Base Fleld: | District =]

Bese Jom: TS I - |

]
]
0
3 L]
3





image31.png
Governorate T District - | IDPs Families IDPs Families Col%

= Dahuk Amedi 2,913 12.93%
Dahuk 4,184 18.57%

Sumel 15,428 68.49%

Dahuk Total 22,525 100.00%

Grand Total 22,525 100.00%




image32.png
I\Amm-thH

IDPs Families  IDPs Families -

Governorate -7 1-1000 1001-2000 2001-3000 4001-5000 Grand Total
Basrah 0.00% 0.00% 0.00%
Dahuk ] sisa%ll 9.60% I | 39.13% [ | 19.76%

Grand Total 32.62% 9.45% 38.50% 19.44%  100.00%




image33.png
‘\Amm.hquu

Count of IDPs Families IDPs Families | -

Governorate /1-1000 1001-2000 2001-3000 4001-5000 Grand Total
Baghdad 76.15% 0.77% 0.00% 0.00% 76.92%
Dahuk 17.69% 1.54% 3.08% 0.77% 23.08%
Grand Total 93.85% 1% 3.08% 0.77%  100.00%





image34.png
Calibri BTN [E > - Swmepted

u 8 Merge & Center -

Pate B 7 U-[E- &-A-

Clipboard 1 Font & Alignment &
ca ~( £e| 1220

1

2

3 Govemnorate - | IDPs Families

4| SAnbar 1,220]

5 2,713





image35.png
1

]

3 Governorate ~ | District ~ | IDPs Families
4| = Anbar AlKa'im 1,220]
3 VPN

5 Top10Ttems

4 Format cells that rank in the TOP:

]

5 5 [2] with [Light Red Fill with Dark Red Text [v]
)

1

2 =Bal EE

3

Al-Musayab 589




image36.png
1

3

3 Governorate | - District - | 1DPs Families

4 | = Anbar AlKa'im 1,220]
> Apply formatting rule to ...

6

> 0 Selectedcells

g | | O Allcells showing " IDPs Families” values

o | |[B] Al cells showing * IDPs Families” values for "District”





image37.png
Governorate | District ~ | IDPs Families

=Baghdad Abu Ghraib 2,262
Adhamia 412
Al Resafa 306
Kadhimia 899
Karkh 737
Mada'in 641
Mahmoudiya 2314
Tarmia 260
Thawra2 903
=Basrah Abu Al-Khaseeb 83
Al-Midaina 58
Al-Qura 36
Al-Zubair 19
Basrah 88
Fao 20
Shatt Al-Arab 67

Grand Total 9,105




image38.jpeg
Grand | Report Blank | _PivotTable
[Totals - Layout - Rows | Style Options *

pivotTable styles I

Do Not Show Subtotals

x| Tarmia

Show all Subtotals at Top of Group 7 | District - | IDPs Families
Abu Ghraib 2,262
g Adhamia 412

2 Include Filered Items in Totals
Al Resafa 306

D |

| PivotTable Field List

Choose fields to add to repor





image39.png
|

1
2

3 Governorate | |District - | 1DPs Families
4  =Baghdad Abu Ghraib 2,262
5 Adhamia 412
6 Al Resafa 306
7 Kadhimia 899
8 Karkh 737
9 Mada'in 641
10 Mahmoudiya 2314
11] 260
12 903
13 Baghdad Total I 8734
14| =Basrah Abu Al-Khaseeb 83
15 Al-Midaina 58
16 Al-Qura 36
17 Al-Zubair 19
18 Basrah 88
19 Fao 20
20 Shatt Al-Arab 67
21 Basrah Total ] 371

22 Grand Total 9,105




image40.png
Governorate

IDPs

IDP

.gmawmmaqup

| |

Families _ Individuals

Anbar Al-Ka'im 154 (924

Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816

Erbil Erbil 34 |204

Kerbala AlHindya | 161|966

Erbil Makhmor | None




image41.png
Elgle/e v awa ey~

£ | =COUNT(C2:C8)

Governorate

District

C D
IDPs IDP

| |

Families _ Individuals

Anbar Al-Ka'im 154 (924

Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816

Erbil Erbil 34 |204

Kerbala AlHindya | 161|966

Erbil Makhmor | None





image42.png
Els]e]» ~ o waluln -

'>=100

Governorate

District

C
IDPs
Families

Anbar Al-Ka'im 154
Anbar Falluja 210
Baghdad Abu Ghraib| 164
Baghdad Adhamia 136
Erbil Erbil 34
Kerbala AlHindiya | 161
Erbil Makhmor 60

| |





image43.png
E[z]ele/~ oo s wnm

5

| =SUMIF(A2:A8,"Baghdad",D2:D8)

Governorate

District

IDPs

Fal

C

Anbar Al-Ka'im 154
Anbar Falluja 210
Baghdad Abu Ghraib| 164
Baghdad Adhamia 136
Erbil Erbil 34
Kerbala AlHindiya | 161
Erbil Makhmor 60

-





image44.png
B11 - £ | =VLOOKUP("Erbil",A2:C8,3,FALSE)

-
&

C D E
IDPs IDP

District

Governorate

Families _ Individuals
Anbar Al-Ka'im 154 (924
Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816
Erbil Erbil 34 |204
Kerbala AlHindya | 161|966
Erbil Makhmor 60  |360
34.

slElsle e ~fovlawine




image45.png
B11 - £ | =AVERAGEIF(A2:A8,"Anbar",D2:D8)

C D E
IDPs IDP

Governorate District

Families _ Individuals
Anbar Al-Ka'im 154 (924
Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816
Erbil Erbil 34 |204
Kerbala AlHindya | 161|966
Erbil Makhmor 60  |360
109:

.gwwwnmwau




image46.png
FFSET(B1,1,2,1,1)

C D
IDPs
Families
Anbar Al-Ka'im 154
Anbar Falluja 210
Baghdad Abu Ghraib| 164
Baghdad Adhamia 136
Erbil Erbil 34
Kerbala AlHindiya | 161
Erbil Makhmor 60

Governorate District

.gmawmmaqup

924




image47.png
£ | =MATCH(60,C2:C8,0)

Governorate

D
IDP

1 Families _ Individuals
2 Anbar Al-Ka'im 154 (924

3 Anbar Falluja 210  [1,260

4 Baghdad AbuGhraib| 164 [984

5 Baghdad Adhamia 136|816

6 Erbil Erbil 34 |204

7 Kerbala AlHindya | 161|966

8 Erbil Makhmor 60  |360

9

a




image48.png
B11

Governorate

District

IDPs

1 Fa

2 Anbar Al-Ka'im 154
3 Anbar Falluja 210
4 Baghdad AbuGhraib| 164
5 Baghdad Adhamia 136
6 Erbil Erbil 34
7 Kerbala AbHindiya | 161
& Erbil Makhmor 60
9

10

1 [Makhmor





image49.png
£ | =LARGE(C2:C8,1)

Governorate

District

IDPs

C

D
IDP

.gmawmmaqup

Families _ Individuals
Anbar Al-Ka'im 154 (924
Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816
Erbil Erbil 34 |204
Kerbala AlHindya | 161|966
Erbil Makhmor 60  |360
210




image50.png
District  IDPs IDP
Families _ Individuals
Anbar Al-Ka'im 154 (924

Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816

Erbil Erbil 34 |204
Kerbala AlHindya | 161|966

Erbil Makhmor 60  |360

Governorate

.Ew&wmm.hwruu

|Smaller




image51.png
(C3<C4,"C3 is Smaller than C4",IF(C4<C5,"C4 is Smaller than C5",IF(C5>C6,"C5 is Greater than C6")))

C D E F G H ! J K
IDPs IDP

Governorate District

Families _ Individuals
Anbar Al-Ka'im 154 (924
Anbar Falluja 210  [1,260
Baghdad AbuGhraib| 164 [984
Baghdad Adhamia 136|816
Erbil Erbil 34 |204
Kerbala AlHindya | 161|966
Erbil Makhmor 60  |360
C5is. Greal} than C6

.gwwwnmwau




image52.png
QM rome | mset | Pagelaout  Fomuias Review Developer
i HED R a iXXX.lh

PivotTable Pidure Clip  Shapes Smartart Sacenshot | Column Line  Ple  Bar  Area Scate
3 o ST

Tables Tustrations Charts





image53.png
AL -

Governorate

IDPs
Families

IDP

Individuals

|AIKa'im 154 (924 |
{Anbar Falluja 210 [1,260 J
{Baghdad AbuGhraib| 164 [984 |
{Baghdad Adhamia 136|816 |
{Erbil Erbil 34 [204 |
iKerbala AlHindya | 161|966 J

Create Table

L8 sl

Where is the data for your table?





image54.png
© N o v s w

c2 hd £ 34
A B
ove D DP DP
S L1

Erbil Erbil 34 204
Erbil Makhmor 60 360
Baghdad Adhamia 136 816
Anbar Al-Ka'im 154 924
Kerbala Al-Hindiya 161 966
Baghdad Abu Ghraib 164 984
Anbar Falluja 210 1,260





image55.png
D9 - f| =SUBTOTAL(109,[IDP Individuals])
A B C
Governorate _ District _ IDPs Families  IDP Individuals

1 - |

2 Erbil Erbil 34 204

3 Erbil Makhmor 60 360

4 Baghdad Adhamia 136 816

5 Anbar AlKa'im 154 924

6 Kerbala Al-Hindiya 161 966

7 Baghdad Abu Ghraib 164 984

8 Anbar Falluja 210 1,260

9 [Total 5,514

10 Tone
Average

1 Count

12 Count Numbers
Max

13 Min

14
StdDev

15 Var

16 More Functons...





image56.png
SUMIF v (© X & f& | =[@[IDPs Families]]*6

A B C

Fll Governoratelg D s a B] 1P Individ
Erbil Erbil 34 =[@[IDPs

3 Enbil Makhmor 60 Families]]*6
4 Baghdad 136
5 Anbar AlKa'im 154
6 Kerbala Al-Hindiya 161
7 Baghdad Abu Ghraib 164
& Anbar Falluja 210
9 Total o





image57.png
I fome  inset  Pagelaout  Foruias  Data  Review  View | Developer

B ot . € B R W T

Visual Macros Addins COM | Insert Desion Source
e A\ Macro security adddns| - Mode @ RunDialog @ e
Coae Addins Controls
Q22 | Record Macro
A | Recordamacro. 3 F s H !

Each of the commands you perform
will be saved into the macro so
that you can play them back again.

LN




